Please share your experience with the VA-Beast and Midi

Questions and Discussions about the G-Stomper VA-Beast Synthesizer
User avatar
planet-h
Posts: 1211
Joined: Wed Jun 19, 2013 4:46 pm

Re: Please share your experience with the VA-Beast and Midi

Postby planet-h » Wed Jun 28, 2017 7:17 am

TIXE DOPE wrote:When I used a Midi controller (Samson Graphite mf8) I would have to turn the nobs really fast and hard for it to trigger In the app and when they did trigger the parameter in the app would only go so far and then stop. And if I would try to turn the nob to adjust it the parameter would reset and go back to zero and I would have to turn it again and again. (almost like the "initialize parameter automation" function). Same with faders, any time I move a fader it resets and starts from zero no matter where the actual fader on the controller is held.

That sounds like your controller is sending relative parameter values (+1/-1) instead of absolute values (0..127).
Please check your controller configuration. There must be an option to switch the knobs from relative to absolute.
G-Stomper does only handle absolute cc values from 0 to 127.

TIXE DOPE wrote:also when play keys on a keyboard (arturia minilab) you have to hit the keys really hard and fast for them trigger, and even though you hit them very hard every time there is still a big variance in velocity from very quiet to loudest. I was hoping there would be a velocity range or a set velocity that could be preset for your keyboard.

That is actually weird.
How do the knobs react on the minilab? Same behavior as the Samson Graphite mf8?

Do you have multiple controllers connected to G-Stomper at the same time?
Try it with the minilab alone, and without any USB hub in between.
Also try another USB OTG cable + another USB cable (not all cables work well with all devices).
TIXE DOPE
Posts: 22
Joined: Wed Dec 16, 2015 7:35 pm

Re: Please share your experience with the VA-Beast and Midi

Postby TIXE DOPE » Wed Jun 28, 2017 11:01 pm

Yea the minilab nobs work the same. I have to turn them really fast to trigger and it will go to a certain point in to app and if I try to adjust the nob again I will reset and begin from zero.

And no I can only use one controller at a time. I dont know if it the Otg cable that causing but I've had two different ones and both its done it with both of them. I can invest in a new and let you know how it goes.
User avatar
planet-h
Posts: 1211
Joined: Wed Jun 19, 2013 4:46 pm

Re: Please share your experience with the VA-Beast and Midi

Postby planet-h » Thu Jun 29, 2017 7:43 am

TIXE DOPE wrote:Yea the minilab nobs work the same. I have to turn them really fast to trigger and it will go to a certain point in to app and if I try to adjust the nob again I will reset and begin from zero.

And no I can only use one controller at a time. I dont know if it the Otg cable that causing but I've had two different ones and both its done it with both of them. I can invest in a new and let you know how it goes.


OK, thanks for the explanation.
So it seems that it's not related with relative or absolute messages.

It might be that your Android device does not provide enough power (electric USB power) to feed the MIDI controller.
Have you tried any other apps?
If not, that would be a helpful test.
If other apps behave the same way, then it's most likely a power problem.

You can work around that by using a self powered USB hub.

Return to “G-Stomper VA-Beast Questions and Discussions”

Who is online

Users browsing this forum: No registered users and 0 guests