Midi Issues

Questions and Discussions about G-Stomper
AndreasH
Posts: 9
Joined: Sat Apr 04, 2015 8:27 pm

Midi Issues

Postby AndreasH » Sat Apr 04, 2015 8:35 pm

Hi!

I'm having trouble getting my midi controller (Akai Mpk Mini mk2) to work with G-Stomper Studio on my Nexus 5. I connect the controller, I get a message "USB MIDI Device "AKAI Mpkmini2"has been detached", but I can't use it. Nothing happens when I press the keys. I have checked my settings, and VT01 is set to all channels. Caustic works with the controller, and when I start Caustic I get the question whether I want to give Caustic access to the USB device. This message usually doesn't appear when I start G-Stomper, although it has appeared once or twice, but even when giving access I can't get it to work.
Any help?

Thank you in advance!

/Andreas Hygrell

EDIT: I have noticed that the "giving access to USB device"-window does appear every time, I just have to wait a bit. But that still doesnt solve the issue, no notes are played when I press the controller.
User avatar
planet-h
Posts: 1323
Joined: Wed Jun 19, 2013 4:46 pm

Re: Midi Issues

Postby planet-h » Sun Apr 05, 2015 2:06 pm

Welcome to the forum AndreasH

You mean you get the message "USB MIDI Device "AKAI Mpkmini2"has been attached" (not detached), right?

You probably allowed G-Stomper to use the MIDI device permanently (allow always), therefore you don't get the message anymore.
Can you please do the following:

1. Reboot your device
2. Start G-Stomper Studio, Rhythm or VA-Beast
3. Once G-Stomper started, attach the midi device

Once it's attached, try to play the keys on the controller.
Does it work now?

If not, try to play the on screen keyboard of the VA-Beast Synth. Do you hear anything then (while the MIDI device is attached)?
AndreasH
Posts: 9
Joined: Sat Apr 04, 2015 8:27 pm

Re: Midi Issues

Postby AndreasH » Sun Apr 05, 2015 3:16 pm

Thank you for your reply!
Yes I meant attached, sorry :)
I tried your solution but it didn't work. I tried using the onscreen keyboard, and it worked and I get sound. As far as I can tell, everything except the midi input works.
User avatar
planet-h
Posts: 1323
Joined: Wed Jun 19, 2013 4:46 pm

Re: Midi Issues

Postby planet-h » Sun Apr 05, 2015 4:45 pm

Thanks for the quick feedback.
Ok, then, can you please reset the G-Stomper Settings?

Go to:
System Settings / apps / G-Stomper Studio / clear cache and data

Then start G-Stomper Studio and try again.

Does this change anything?
AndreasH
Posts: 9
Joined: Sat Apr 04, 2015 8:27 pm

Re: Midi Issues

Postby AndreasH » Sun Apr 05, 2015 5:04 pm

No luck clearing data, still not working :(

Is there anything in the settings I can have set incorrectly? Except for setting "all channels" for the synth that I'm using, because I've done that. Otherwise I think it could be a bug in android, because some weird things like the screen freezing or the phone rebooting do happen sometimes when I plug in the controller. It's strange that it works with caustic though. (The screen does freeze sometimes in caustic too, but caustic receives midi data, that's what I mean by "it works")
User avatar
planet-h
Posts: 1323
Joined: Wed Jun 19, 2013 4:46 pm

Re: Midi Issues

Postby planet-h » Sun Apr 05, 2015 5:42 pm

If you did this:

System Settings / apps / G-Stomper Studio / clear cache and data

Then you completely reset the settings to the default (which should always work out of the box)

It's strange that it works with caustic though. (The screen does freeze sometimes in caustic too, but caustic receives midi data, that's what I mean by "it works")


Yes, that's indeed a bit strange, since Rej and me are using more or less the same Midi driver.
Are you connecting the Midi device directly over USB? or are you using a USB to MIDI converter Cable as described here?
http://www.planet-h.com/documentation/midi/
AndreasH
Posts: 9
Joined: Sat Apr 04, 2015 8:27 pm

Re: Midi Issues

Postby AndreasH » Sun Apr 05, 2015 6:12 pm

I'm using a "USB Female to Micro USB Male OTG Cable Adapter", connecting directly via USB otg.
User avatar
planet-h
Posts: 1323
Joined: Wed Jun 19, 2013 4:46 pm

Re: Midi Issues

Postby planet-h » Mon Apr 06, 2015 6:26 am

Unfortunately I have neither a nexus 5 nor an Akai Mpkmini2 to test with.
But I'll contact Rej for that, maybe he can give me some advice regarding this problem.
There's anyway a major MIDI update coming in the near future, and I'll definitely look into that issue too.
Are you a google play buyer? If you are, I can invite you to the G-Stomper Beta community.
Members getting new releases sooner than the public.
All I need is your google account email (the one you've used to buy G-Stomper).

It'll probably take another week until the next beta is ready, since I have to deal with an ugly Android 5.1 issue first, but it's on it's way.
User avatar
planet-h
Posts: 1323
Joined: Wed Jun 19, 2013 4:46 pm

Re: Midi Issues

Postby planet-h » Mon Apr 06, 2015 7:55 am

Btw. What Android version are you on?
Did you update already to 5.1?
That might also be the cause. The midi driver is not tested yet with 5.1.
AndreasH
Posts: 9
Joined: Sat Apr 04, 2015 8:27 pm

Re: Midi Issues

Postby AndreasH » Mon Apr 06, 2015 7:59 am

Yes, I'm running 5.1.
I only have it since a few days, and it feels like I already tried using the controller before that, but I am not sure, so that could be the reason.

Return to “General Questions and Discussions”

Who is online

Users browsing this forum: No registered users and 2 guests