Important Notice for Samsung users (Android 5.1.1)

Submit any bugs here. Please check existing posts before submitting a new one.
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Thu Feb 25, 2016 8:05 am

G-Stomper (and many other music making apps) might not work with USB MIDI equipment when running Samsung Android 5.1.1.

Due to a bug in the permission system of the Samsung Android 5.1.1 update, it is not possible to use USB MIDI devices on certain Samsung models. Please note that this problem also occurs in many other apps, so it’s definitely not a bug in G-Stomper.

So far, the problem has been reported for the following devices (first appearance in early October 2015):

Galaxy S5
Galaxy Tab Pro 12.2
Galaxy Tab E 9.6
Galaxy Tab 4 7

If you can choose, please do not install any system updates until Samsung has fixed the problem. The bug is already reported to Samsung, but if you run into that problem, please let Samsung know about it. As more reports they get as higher the chance that it’ll be fixed soon.

Update:
I just updated my Galaxy S5 to Android 6.0.1 today and USB MIDI connections are working as expected again.
Obviously Samsung fixed the problem in Marshmallow. Thank you Samsung;)
TheMaartian
Posts: 1
Joined: Fri Feb 26, 2016 4:03 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby TheMaartian » Fri Feb 26, 2016 4:28 pm

I have a Google Nexus 10 tablet (manufactured by Samsung). Google has capped the Android OS version of the Nexus 10 at v5.1.1 (which I am at). Instead of further version updates to the OS, Google apply a monthly patch, so my current version is v5.1.1 with the February 2016 patch.

In addition to G-Stomper Studio, I have the Audio Evolution Mobile DAW with the USB audio driver and USB MIDI driver options installed.

A couple of days ago, my new mics arrived (switching to M/S recording vs. ORTF and needed a (more or less) matched pair that could be switched between cardioid and figure-8 pick up patterns. I attached my audio i/f to the Nexus 10, started up AE Mobile, and selected their audio driver.

That's when all hell broke loose. G-Stomper started throwing up messages about defaulting to that driver...and I wasn't even running G-S?!?!

I'm guessing that I'm experiencing the bug you mention. This did not occur 3-4 months ago (the previous time I connected my audio i/f), so I suspect the bug was introduced in one of the following monthly updates (December 2015, January 2016, February 2016 for sure; perhaps November 2015 as well).

Samsung hardware. Pure Google Android v5.1.1.
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Fri Feb 26, 2016 5:21 pm

Thanks for your message, TheMaartian, and welcome to the forum.

TheMaartian wrote:I have a Google Nexus 10 tablet (manufactured by Samsung). Google has capped the Android OS version of the Nexus 10 at v5.1.1 (which I am at). Instead of further version updates to the OS, Google apply a monthly patch, so my current version is v5.1.1 with the February 2016 patch.

In addition to G-Stomper Studio, I have the Audio Evolution Mobile DAW with the USB audio driver and USB MIDI driver options installed.

A couple of days ago, my new mics arrived (switching to M/S recording vs. ORTF and needed a (more or less) matched pair that could be switched between cardioid and figure-8 pick up patterns. I attached my audio i/f to the Nexus 10, started up AE Mobile, and selected their audio driver.

That's when all hell broke loose. G-Stomper started throwing up messages about defaulting to that driver...and I wasn't even running G-S?!?!

What you report here is either the regular notification of the broadcast receiver in G-Stomper (which listens for all USB MIDI connections), or G-Stomper was running in the background. Just click no if in that situation, that's just a regular Android Dialog. If you have more other MIDI capable apps installed you see a list of available apps to be used with the audio interface. Why G-Stomper reacts on that interface is because it provides a MIDI interface in addition to the audio part.

TheMaartian wrote:I'm guessing that I'm experiencing the bug you mention. This did not occur 3-4 months ago (the previous time I connected my audio i/f), so I suspect the bug was introduced in one of the following monthly updates (December 2015, January 2016, February 2016 for sure; perhaps November 2015 as well).

Samsung hardware. Pure Google Android v5.1.1.


As you say, it's pure Google Stock Android. Therefore it's technically impossible that you ran into that bug. The bug is not based on Samsung hardware, it's caused by Samsungs modified Android 5.1.1 OS, it's located in Samsungs security system. It results in a security exception when an app tries to ask for permission.

And, the bug on those Samsung devices makes it impossible to use any USB Audio or MIDI hardware, in any app, also in Audio Evolution Mobile.
There's a notice about it in the Audio Evolution Mobile driver description.
http://www.extreamsd.com/index.php/2015-07-22-12-01-14/usb-audio-driver
Scroll down to the "Notice for Samsung users (10 October 2015)"
stevendaneker
Posts: 1
Joined: Mon Mar 28, 2016 12:18 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby stevendaneker » Mon Mar 28, 2016 12:22 pm

Can you post a link to directy contact Samsung to complain about the issue? :twisted:
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Tue Mar 29, 2016 6:59 am

stevendaneker wrote:Can you post a link to directy contact Samsung to complain about the issue? :twisted:


I didn't post the link here to avoid that a lot of people report the bug to Samsung even if they're unsure if it actually is this specific bug.
I've just sent the link to your email address.
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Thu Jun 16, 2016 4:01 pm

Update:
I just updated my Galaxy S5 to Android 6.0.1 today and USB MIDI connections are working as expected again.
Obviously Samsung fixed the problem in Marshmallow. Thank you Samsung;)
vanjub
Posts: 6
Joined: Thu Aug 10, 2017 4:52 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby vanjub » Tue Aug 15, 2017 10:19 am

Samsung 705 tab 8.4 cm 12.1 (5.X.X) Also does not want to connect, even USB Mass Storage Enabler does not help. Is it possible to use something like "Image-Line Remote" through wifi?
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Tue Aug 15, 2017 4:48 pm

vanjub wrote:Samsung 705 tab 8.4 cm 12.1 (5.X.X) Also does not want to connect, even USB Mass Storage Enabler does not help.

When you say Samsung 705 tab, you mean the Samsung Galaxy Tab S 8.4, right?
As the problem is caused by an operating system bug in Samsung's Android 5.1.1, you simply cannot use any USB MIDI hardware as long as you're on this Android version..

I might be wrong, but as far as I know you should get an update to Android Marshmallow (6.x), don't you?

See here:
http://www.techtimes.com/articles/176618/20160907/samsung-galaxy-tab-s-8-4-gets-android-marshmallow.htm
That would definitely solve your problem.

vanjub wrote:Is it possible to use something like "Image-Line Remote" through wifi?

No, unfortunately not.
vanjub
Posts: 6
Joined: Thu Aug 10, 2017 4:52 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby vanjub » Tue Aug 15, 2017 5:04 pm

Yes Tab S 8.4, Custom firmware Cyanogen 12.1. Well I have to install Marshmallow (6.x) and all again to adjust and install a heap of applications :cry: By the way g-stomper works fine in BlueStacks 3 (android emulator for pc) and you can across "virtual audio cable" and "AudioRouter" send sound to daw.
User avatar
planet-h
Posts: 1198
Joined: Wed Jun 19, 2013 4:46 pm

Re: Important Notice for Samsung users (Android 5.1.1)

Postby planet-h » Tue Aug 15, 2017 5:46 pm

vanjub wrote:Yes Tab S 8.4, Custom firmware Cyanogen 12.1. Well I have to install Marshmallow (6.x) and all again to adjust and install a heap of applications :cry:

And you're sure that you're running into the Samsung security bug?
As you're using a Cyanogen Mod, it could also be another problem.
Did you try to hook up the MIDI controller with other apps?
Did you try another MIDI controller with G-Stomper?
What happens if you hook up your controller while G-Stomper is started?

vanjub wrote:By the way g-stomper works fine in BlueStacks 3 (android emulator for pc) and you can across "virtual audio cable" and "AudioRouter" send sound to daw.

That's nice to hear. I didn't know that there was a new BlueStacks version lately.
Is it still not possible in the latest BlueStacks version to use USB MIDI hardware?

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest