[SOLVED] Exporting multiple patterns contains blank audio

Submit any bugs here. Please check existing posts before submitting a new one.
howard7000
Posts: 2
Joined: Tue Dec 04, 2018 3:52 am

[SOLVED] Exporting multiple patterns contains blank audio

Postby howard7000 » Tue Dec 04, 2018 4:02 am

I've been happily using G-Stomper on my Kindle Fire 1 for the last year. I recently upgraded to a Kindle Fire 7 and re-installed the app on my new device. It seems to run the same, except I've noticed when I "export multiple patterns as audio" and select Export Tracks Separately, it spits out a load of blank wav files for certain tracks, even though I know some of those should contain sounds. I'm sure it didn't do this on my previous version.

The version I'm currently using on my Kindle 7 is 5.7.4 (I checked the version installed on my older device and it was 5.6.3)

Thanks
User avatar
planet-h
Posts: 1167
Joined: Wed Jun 19, 2013 4:46 pm

Re: Exporting multiple patterns contains blank audio

Postby planet-h » Tue Dec 04, 2018 7:10 am

Welcome to the forum, howard7000
And thanks for your message.

howard7000 wrote:I've been happily using G-Stomper on my Kindle Fire 1 for the last year. I recently upgraded to a Kindle Fire 7 and re-installed the app on my new device. It seems to run the same, except I've noticed when I "export multiple patterns as audio" and select Export Tracks Separately, it spits out a load of blank wav files for certain tracks, even though I know some of those should contain sounds. I'm sure it didn't do this on my previous version.

The version I'm currently using on my Kindle 7 is 5.7.4 (I checked the version installed on my older device and it was 5.6.3)

I drove some decent tests this morning, but unfortunately wasn't able to reproduce the behavior you describe.

I've exported multiple patterns as audio with different settings (as separate track stems as you did), once with a selection of patterns, once with all patterns of the pattern set chosen. The result was always exactly as it should be.

Can you please send me the pattern set you export by mail (main menu / help / contact developer), together with a short description how exactly I can reproduce the problem.
(if the pattern set file is too large for an email, just upload it to your cloud storage and send me a download link)

Thanks in advance
howard7000
Posts: 2
Joined: Tue Dec 04, 2018 3:52 am

Re: Exporting multiple patterns contains blank audio

Postby howard7000 » Tue Dec 04, 2018 10:31 pm

Hi, thanks for getting back to me so quick. Well, this is a bit embarrassing: I just re-opened all the project files where I'd encountered this problem and I tried re-exporting all the patterns as stems. This time around all the wavs exported correctly - either there was an intermittent fault this morning that I can't replicate now, or my brain went temporarily wrong! For now I'll have to assume it's the latter, but I'll keep my eyes peeled in case the export issue happens again at any future time.

Sorry if I wasted your time!
User avatar
planet-h
Posts: 1167
Joined: Wed Jun 19, 2013 4:46 pm

Re: Exporting multiple patterns contains blank audio

Postby planet-h » Wed Dec 05, 2018 7:59 am

howard7000 wrote:Hi, thanks for getting back to me so quick. Well, this is a bit embarrassing: I just re-opened all the project files where I'd encountered this problem and I tried re-exporting all the patterns as stems. This time around all the wavs exported correctly - either there was an intermittent fault this morning that I can't replicate now, or my brain went temporarily wrong! For now I'll have to assume it's the latter, but I'll keep my eyes peeled in case the export issue happens again at any future time.

Sorry if I wasted your time!

No problem at all, Howard. I'm glad to hear that it worked as expected.

There are some very rare situations, in which the app cannot write data to the storage.
These rare problems are caused by the Android operating system and its storage handling.
So it could be that you ran in such a situation.

However, thanks a lot for the success report.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 0 guests