Audio Clicks on Galaxy Nexus 7

Submit any bugs here. Please check existing posts before submitting a new one.
taerundfehder
Posts: 14
Joined: Tue Nov 26, 2013 3:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby taerundfehder » Wed Feb 19, 2014 12:16 pm

Hey there,
Long time ago but now i finally found time to play a lot with the va beast and gstomper studio 2.


I can say that i have the same clicks appearing almost every time. This is sad and makes it unusable for me. Wanted to have the app as live drum machine beside my analogue setup.

Tablet: Asus transformer tf300tl

Flight mode: activated

Cache: cleared

All apps closed, power management switched to normal, energy saving settings switched off. [Edit:] No Auto-haptic setting available.


Is there a fix, too? Maybe it's the same sample rate problem?!


Another thing is that i got invited to join the 3.0 beta but accidentally clicked on the wrong (decline) button . So, it's my fault, but i'm not able to install and join that beta. Maybe you can invite me again? :-)

Thanks in advance for any support or help here!

Cheers,
Scott
User avatar
planet-h
Posts: 1359
Joined: Wed Jun 19, 2013 4:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby planet-h » Wed Feb 19, 2014 2:10 pm

Hi Scott
Thanks a lot for your feedback.
The clicks should be fixed in version 3.0. Since it's going live tomorrow, there's no more need for the beta ;)

The sample rate will be handled completely different in version 3.0. The output of version 3 is always running on the device's native sample rate to avoid the android internal re-sampler to be used. Internally you can set the sample rate as you like: 18kHz, 22kHz, 32kHz, 44.1kHz and (if available) 48kHz.

So let's see how it works with the new release.
Would be great if you could share your experience once you got it.
taerundfehder
Posts: 14
Joined: Tue Nov 26, 2013 3:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby taerundfehder » Wed Feb 19, 2014 3:53 pm

Great news! The update to version 3.0 is free?
Thanks for your reply!
User avatar
planet-h
Posts: 1359
Joined: Wed Jun 19, 2013 4:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby planet-h » Wed Feb 19, 2014 4:07 pm

taerundfehder wrote:Great news! The update to version 3.0 is free?
Thanks for your reply!


Yes, sure :). It's free for all owners of the G-Stomper Beat Studio full version
taerundfehder
Posts: 14
Joined: Tue Nov 26, 2013 3:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby taerundfehder » Wed Feb 19, 2014 4:31 pm

Very good! Looking forward to this :-) Thanks!
taerundfehder
Posts: 14
Joined: Tue Nov 26, 2013 3:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby taerundfehder » Thu Feb 20, 2014 10:18 am

Didn't want to post that on your Facebook page. Even if the clicks are gone, there is still some kind of a click (only) when switching between views.

Flight mode activated
All apps closed.

Don't think that it depends on my hardware?! (Asus Transformer TF300tl)
User avatar
planet-h
Posts: 1359
Joined: Wed Jun 19, 2013 4:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby planet-h » Thu Feb 20, 2014 10:28 am

I guess, you're talking about G-Stomper Beat Studio 3.0, right?

there is still some kind of a click (only) when switching between view


This means, that the cpu drain is too much for your device. It also strongly depends on your android version, the early 4.0.x releases were still very cpu intensive in the drawing of the screen, android 4.2 and up is much better from this point of view.

Please try one of the following steps:

- Settings / Layout / Select Max Performance Layout
- Settings / Audio / SampleRate ... set to 32000
- Settings / Automated graphical elements / uncheck everything except the LED bars

Of course you don't have to do all of them, ideally play around with the settings to find the best combination for your device.
All of these settings will bring a massive boost of the performance headroom.
SerrArris
Posts: 5
Joined: Wed Feb 25, 2015 4:29 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby SerrArris » Wed Feb 25, 2015 9:19 pm

Hi Andreas and others!

I stumbled over G-Stomper just last week and this could really be the hell of a tool for me (I just never got warm with the sound of RD4). Unfortunatelly, I do expect clicks and audio glitches (audio slows down) on my Nexus 7 2013, Android 5 Lollipop . A latency of 20ms did not work at all, finally I reduced tracks and set audio to normal mode with extended latency (80ms). Even then, the clicks did not vanish completely (but got much less compared to 20 or 40ms). Most disturbing are the audio glitches (slowdown/catchup of the audio speed).

My system is relatively clean with only a few apps installed. When I start G-Stomper Studio it is the only app running. This issue seems strange to me? Anybody has an idea?

Best regards,
Markus
User avatar
planet-h
Posts: 1359
Joined: Wed Jun 19, 2013 4:46 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby planet-h » Thu Feb 26, 2015 7:02 am

Welcome to the forum Markus.
And thank you for your message. Good to hear that you're enjoying G-Stomper Studio:)

SerrArris wrote:I stumbled over G-Stomper just last week and this could really be the hell of a tool for me (I just never got warm with the sound of RD4). Unfortunatelly, I do expect clicks and audio glitches (audio slows down) on my Nexus 7 2013, Android 5 Lollipop . A latency of 20ms did not work at all, finally I reduced tracks and set audio to normal mode with extended latency (80ms). Even then, the clicks did not vanish completely (but got much less compared to 20 or 40ms). Most disturbing are the audio glitches (slowdown/catchup of the audio speed).

My system is relatively clean with only a few apps installed. When I start G-Stomper Studio it is the only app running. This issue seems strange to me? Anybody has an idea?


First of all, what exact Android version are you running? 5.0, 5.0.1 or 5.0.2? Or any modded version?

Then, the first thing you should do is to reset the G-Stomper settings to the defaults:
System Settings / apps / G-Stomper Studio / Clear cache and data

When you did that, G-Stomper Studio comes up with 12 Sampler Tracks, 5 Synth Tracks, 4 Synth voices, AudioSystem = AudioTrack, SampleRate = native 48000Hz, and all other settings at the defaults.

Do you still notice the glitches then?

Regarding the lower latency (20ms): Yes, with the low latency setting, there may be clicks, depending on the Android version. But that should be really few. I have a nexus 7 2013 here for testing too, which runs completely clean on AudioTrack with all settings defaulted. But I also notice minor clicks with the lowest latency setting on OpenSL. What you can try is to enable the "use higher latency" checkbox in combination with OpenSL (that would result in 40ms). Think that should make it better.

Bottom line, it's all about performance. As more cpu headroom you give to the audio processing, as cleaner it runs (e.b. by disabling some of the animated ui components in the setup).
This guide gives a good direction:
http://www.planet-h.com/gstomper/docs/pdf/G-Stomper_UserManual_Performance.pdf

Let me know if that helped
Andreas
SerrArris
Posts: 5
Joined: Wed Feb 25, 2015 4:29 pm

Re: Audio Clicks on Galaxy Nexus 7

Postby SerrArris » Thu Feb 26, 2015 10:11 am

Dear Andreas!

I'm running Android 5.0.2 without any modifications.

I followed your steps (Default settings, reboot, max performance layout, flight mode, AudioTrack). Even then, there are a lot clicks and glitches, rendering the sound output pretty unusable (definetly not "minor"). With OpenSL and LowLatency its pretty much "Only clicks".

Any further ideas?

Best regards,
Markus

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest